What’s Vulnerable › Vulnerabilities
CVE-2024-25578: MicroDicom DICOM Viewer Out-of-Bounds Write
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-787
Description
MicroDicom DICOM Viewer versions 2023.3 (Build 9342) and prior contain a lack of proper validation of user-supplied data, which could result in memory corruption within the application.
Affected products
- MicroDicom DICOM Viewer: before 2024.1 — fixed in 2024.1
How to fix
Upgrade to a fixed version: MicroDicom DICOM Viewer 2024.1. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-060-01
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-060-01
Get alerted when CVE-2024-25578 or the next vulnerability affects your stack