What’s Vulnerable › Vulnerabilities

CVE-2024-25580

Description

An issue was discovered in gui/util/qktxhandler.cpp in Qt before 5.15.17, 6.x before 6.2.12, 6.3.x through 6.5.x before 6.5.5, and 6.6.x before 6.6.2. A buffer overflow and application crash can occur via a crafted KTX image file.

Affected products

How to fix

Upgrade to a fixed version: Qt 5.15.17, 6.2.12, 6.5.5, 6.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-25580 or the next vulnerability affects your stack