What’s Vulnerable › Vulnerabilities
CVE-2024-25593: WordPress NEX-Forms plugin <= 8.5.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basix NEX-Forms – Ultimate Form Builder allows Stored XSS.This issue affects NEX-Forms – Ultimate Form Builder: from n/a through 8.5.5.
Affected products
- webaways NEX-Forms – Ultimate Forms Plugin for WordPress: before 8.5.6 — fixed in 8.5.6
How to fix
Upgrade to a fixed version: webaways NEX-Forms – Ultimate Forms Plugin for WordPress 8.5.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/nex-forms-express-wp-form-builder/wordpress-nex-forms-plugin-8-5-5-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/nex-forms-express-wp-form-builder/wordpress-nex-forms-plugin-8-5-5-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-25593 or the next vulnerability affects your stack