What’s Vulnerable › Vulnerabilities
CVE-2024-25595: WordPress Defender Security plugin <= 4.4.1 - IP Restriction Bypass vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-290
Description
Authentication Bypass by Spoofing vulnerability in WPMU DEV Defender Security allows Functionality Bypass.This issue affects Defender Security: from n/a through 4.4.1.
Affected products
- WPMU DEV Defender Security: before 4.4.2 — fixed in 4.4.2
How to fix
Upgrade to a fixed version: WPMU DEV Defender Security 4.4.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/defender-security/wordpress-defender-security-plugin-4-4-1-ip-restriction-bypass-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/defender-security/wordpress-defender-security-plugin-4-4-1-ip-restriction-bypass-vulnerability?_s_id=cve
Get alerted when CVE-2024-25595 or the next vulnerability affects your stack