What’s Vulnerable › Vulnerabilities

CVE-2024-25610

Description

In Liferay Portal 7.2.0 through 7.4.3.12, and older unsupported versions, and Liferay DXP 7.4 before update 9, 7.3 before update 4, 7.2 before fix pack 19, and older unsupported versions, the default configuration does not sanitize blog entries of JavaScript, which allows remote authenticated users to inject arbitrary web script or HTML (XSS) via a crafted payload injected into a blog entry’s content text field.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 7.2; Liferay Portal 7.4.3.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-25610 or the next vulnerability affects your stack