What’s Vulnerable › Vulnerabilities
CVE-2024-25614
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-22
Description
There is an arbitrary file deletion vulnerability in the CLI used by ArubaOS. Successful exploitation of this vulnerability results in the ability to delete arbitrary files on the underlying operating system, which could lead to denial-of-service conditions and impact the integrity of the controller.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 8.10.0.0 before 8.10.0.10; from 8.11.0.0 before 8.11.2.1; from 10.4.0.0 before 10.4.1.0; from 10.5.0.0 before 10.5.1.0 — fixed in 10.4.1.0, 10.5.1.0, 8.10.0.10, 8.11.2.1
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.1.0, 10.5.1.0, 8.10.0.10, 8.11.2.1. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-002.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-002.txt
Get alerted when CVE-2024-25614 or the next vulnerability affects your stack