What’s Vulnerable › Vulnerabilities
CVE-2024-25621: containerd affected by a local privilege escalation via wide permissions on CRI directory
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-06 · updated 2026-06-17
- Weakness: CWE-279
Description
containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.
Affected products
- containerd: before 1.7.29; from 2.0.0 before 2.0.7; from 2.1.0 before 2.1.5; 2.2.0-beta0, 2.2.0-beta1, 2.2.0-beta2, 2.2.0-rc0, 2.2.0-rc1 — fixed in 1.7.29, 2.0.7, 2.1.5
How to fix
Upgrade to a fixed version: containerd 1.7.29, 2.0.7, 2.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/containerd/containerd/blob/main/docs/rootless.md
- https://github.com/containerd/containerd/commit/7c59e8e9e970d38061a77b586b23655c352bfec5
- https://github.com/containerd/containerd/security/advisories/GHSA-pwhc-rpq9-4c8w
Get alerted when CVE-2024-25621 or the next vulnerability affects your stack