What’s Vulnerable › Vulnerabilities
CVE-2024-25627: Cross-Site Scripting (XSS) via File Upload in Alf.io
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Alf.io is a free and open source event attendance management system. An administrator on the alf.io application is able to upload HTML files that trigger JavaScript payloads. As such, an attacker gaining administrative access to the alf.io application may be able to persist access by planting an XSS payload. This issue has been addressed in version 2.0-M4-2402. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- alfio-event alf.io: before 2.0-m4-2304 — fixed in 2.0-m4-2304
How to fix
Upgrade to a fixed version: alfio-event alf.io 2.0-m4-2304. Check the vendor advisory for mitigations.
References
- https://github.com/alfio-event/alf.io/security/advisories/GHSA-gpmg-8f92-37cf
- https://github.com/alfio-event/alf.io/security/advisories/GHSA-gpmg-8f92-37cf
Get alerted when CVE-2024-25627 or the next vulnerability affects your stack