What’s Vulnerable › Vulnerabilities
CVE-2024-25628: Insufficient Session Expiration in alf.io
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-16 · updated 2026-06-17
- Weakness: CWE-613
Description
Alf.io is a free and open source event attendance management system. In versions prior to 2.0-M4-2402 users can access the admin area even after being invalidated/deleted. This issue has been addressed in version 2.0-M4-2402. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- alfio-event alf.io: before 2.0-m4-2402 — fixed in 2.0-m4-2402
How to fix
Upgrade to a fixed version: alfio-event alf.io 2.0-m4-2402. Check the vendor advisory for mitigations.
References
- https://github.com/alfio-event/alf.io/security/advisories/GHSA-8p6m-mm22-q893
- https://github.com/alfio-event/alf.io/security/advisories/GHSA-8p6m-mm22-q893
Get alerted when CVE-2024-25628 or the next vulnerability affects your stack