What’s Vulnerable › Vulnerabilities
CVE-2024-25639: Prompt Injection triggered XSS vulnerability in Khoj Obsidian, Desktop and Web clients
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-80
Description
Khoj is an application that creates personal AI agents. The Khoj Obsidian, Desktop and Web clients inadequately sanitize the AI model's response and user inputs. This can trigger Cross Site Scripting (XSS) via Prompt Injection from untrusted documents either indexed by the user on Khoj or read by Khoj from the internet when the user invokes the /online command. This vulnerability is fixed in 1.13.0.
Affected products
- khoj-ai khoj: before 1.13.0 — fixed in 1.13.0
How to fix
Upgrade to a fixed version: khoj-ai khoj 1.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/khoj-ai/khoj/commit/1dfd6d7391862d3564db7f4875216880b73cb6cc
- https://github.com/khoj-ai/khoj/security/advisories/GHSA-h2q2-vch3-72qm
- https://github.com/khoj-ai/khoj/commit/1dfd6d7391862d3564db7f4875216880b73cb6cc
- https://github.com/khoj-ai/khoj/security/advisories/GHSA-h2q2-vch3-72qm
Get alerted when CVE-2024-25639 or the next vulnerability affects your stack