What’s Vulnerable › Vulnerabilities
CVE-2024-25678
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-354
Description
In LiteSpeed QUIC (LSQUIC) Library before 4.0.4, DCID validation is mishandled.
Affected products
- litespeedtech LSQUIC: before 4.0.4 — fixed in 4.0.4
How to fix
Upgrade to a fixed version: litespeedtech LSQUIC 4.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/lsquic/commit/515f453556c99d27c4dddb5424898dc1a5537708
- https://github.com/litespeedtech/lsquic/releases/tag/v4.0.4
- https://www.rfc-editor.org/rfc/rfc9001
- https://github.com/litespeedtech/lsquic/commit/515f453556c99d27c4dddb5424898dc1a5537708
- https://github.com/litespeedtech/lsquic/releases/tag/v4.0.4
- https://www.rfc-editor.org/rfc/rfc9001
Get alerted when CVE-2024-25678 or the next vulnerability affects your stack