What’s Vulnerable › Vulnerabilities
CVE-2024-25710: Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-19 · updated 2026-06-17
- Weakness: CWE-835
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Compress: from 1.3 before 1.26.0 — fixed in 1.26.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Compress 1.26.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/19/1
- https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf
- https://security.netapp.com/advisory/ntap-20240307-0010/
- http://seclists.org/fulldisclosure/2024/Aug/37
- http://www.openwall.com/lists/oss-security/2024/02/19/1
- https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf
- https://security.netapp.com/advisory/ntap-20240307-0010/
Get alerted when CVE-2024-25710 or the next vulnerability affects your stack