What’s Vulnerable › Vulnerabilities
CVE-2024-25718
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-11 · updated 2026-06-17
- Weakness: CWE-613
Description
In the Samly package before 1.4.0 for Elixir, Samly.State.Store.get_assertion/3 can return an expired session, which interferes with access control because Samly.AuthHandler uses a cached session and does not replace it, even after expiry.
Affected products
- dropbox samly: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: dropbox samly 1.4.0. Check the vendor advisory for mitigations.
References
- https://diff.hex.pm/diff/samly/1.3.0..1.4.0
- https://github.com/dropbox/samly
- https://github.com/dropbox/samly/pull/13
- https://github.com/dropbox/samly/pull/13/commits/812b5c3ad076dc9c9334c1a560c8e6470607d1eb
- https://github.com/handnot2/samly
- https://hex.pm/packages/samly
- https://diff.hex.pm/diff/samly/1.3.0..1.4.0
- https://github.com/dropbox/samly
- https://github.com/dropbox/samly/pull/13
- https://github.com/dropbox/samly/pull/13/commits/812b5c3ad076dc9c9334c1a560c8e6470607d1eb
- https://github.com/handnot2/samly
- https://hex.pm/packages/samly
Get alerted when CVE-2024-25718 or the next vulnerability affects your stack