What’s Vulnerable › Vulnerabilities
CVE-2024-25723
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 70.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-284
Description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Affected products
- zenml-io/zenml: before 0.42.2; from 0.44.0 before 0.44.4; from 0.45.0 before 0.46.7; 0.43.0 — fixed in 0.42.2, 0.44.4, 0.46.7
How to fix
Upgrade to a fixed version: zenml-io/zenml 0.42.2, 0.44.4, 0.46.7. Check the vendor advisory for mitigations.
References
- https://github.com/zenml-io/zenml
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4
- https://www.zenml.io/blog/critical-security-update-for-zenml-users
- https://github.com/zenml-io/zenml
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4
- https://www.zenml.io/blog/critical-security-update-for-zenml-users
Get alerted when CVE-2024-25723 or the next vulnerability affects your stack