What’s Vulnerable › Vulnerabilities
CVE-2024-25734
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered on WyreStorm Apollo VX20 devices before 1.3.58. The TELNET service prompts for a password only after a valid username is entered, which might make it easier for remote attackers to enumerate user accounts.
Affected products
- Wyrestorm Apollo Vx20 Firmware: before 1.3.58 — fixed in 1.3.58
How to fix
Upgrade to a fixed version: Wyrestorm Apollo Vx20 Firmware 1.3.58. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/177081
- https://hyp3rlinx.altervista.org
- http://packetstormsecurity.com/files/177081
- http://seclists.org/fulldisclosure/2024/Feb/9
- https://hyp3rlinx.altervista.org
Get alerted when CVE-2024-25734 or the next vulnerability affects your stack