What’s Vulnerable › Vulnerabilities
CVE-2024-25744
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-693
Description
In the Linux kernel before 6.6.7, an untrusted VMM can trigger int80 syscall handling at any given point. This is related to arch/x86/coco/tdx/tdx.c and arch/x86/mm/mem_encrypt_amd.c.
Affected products
- Linux kernel: before 6.6.7 — fixed in 6.6.7
How to fix
Upgrade to a fixed version: Linux kernel 6.6.7. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.6.7
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b82a8dbd3d2f4563156f7150c6f2ecab6e960b30
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.6.7
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b82a8dbd3d2f4563156f7150c6f2ecab6e960b30
- https://security.netapp.com/advisory/ntap-20241115-0006/
Get alerted when CVE-2024-25744 or the next vulnerability affects your stack