What’s Vulnerable › Vulnerabilities
CVE-2024-25817
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-06 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow vulnerability in eza before version 0.18.2, allows local attackers to execute arbitrary code via the .git/HEAD, .git/refs, and .git/objects components.
Affected products
- Eza.Rock Eza: before 0.18.2 — fixed in 0.18.2
How to fix
Upgrade to a fixed version: Eza.Rock Eza 0.18.2. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-3qx3-6hxr-j2ch
- https://www.cubeyond.net/blog/my-cves/eza-cve-report
- https://github.com/advisories/GHSA-3qx3-6hxr-j2ch
- https://www.cubeyond.net/blog/my-cves/eza-cve-report
Get alerted when CVE-2024-25817 or the next vulnerability affects your stack