What’s Vulnerable › Vulnerabilities
CVE-2024-2583: Shortcodes Ultimate < 7.0.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Shortcodes Plugin — Shortcodes Ultimate WordPress plugin before 7.0.5 does not properly escape some of its shortcodes attributes before they are echoed back to users, making it possible for users with the contributor role to conduct Stored XSS attacks.
Affected products
- gn_themes WP Shortcodes Plugin — Shortcodes Ultimate: before 7.0.5 — fixed in 7.0.5
How to fix
Upgrade to a fixed version: gn_themes WP Shortcodes Plugin — Shortcodes Ultimate 7.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/98d8c713-e8cd-4fad-a8fb-7a40db2742a2/
- https://wpscan.com/vulnerability/98d8c713-e8cd-4fad-a8fb-7a40db2742a2/
Get alerted when CVE-2024-2583 or the next vulnerability affects your stack