What’s Vulnerable › Vulnerabilities
CVE-2024-25841
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
In the module "So Flexibilite" (soflexibilite) from Common-Services for PrestaShop < 4.1.26, a guest (authenticated customer) can perform Cross Site Scripting (XSS) injection.
Affected products
- Common-Services So Flexibilite: before 4.1.14 — fixed in 4.1.14
How to fix
Upgrade to a fixed version: Common-Services So Flexibilite 4.1.14. Check the vendor advisory for mitigations.
References
- https://addons.prestashop.com/fr/transporteurs/2704-colissimo-domicile-et-points-de-retrait.html
- https://security.friendsofpresta.org/modules/2024/02/27/soflexibilite.html
- https://addons.prestashop.com/fr/transporteurs/2704-colissimo-domicile-et-points-de-retrait.html
- https://security.friendsofpresta.org/modules/2024/02/27/soflexibilite.html
Get alerted when CVE-2024-25841 or the next vulnerability affects your stack