What’s Vulnerable › Vulnerabilities
CVE-2024-25858
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-450
Description
In Foxit PDF Reader before 2024.1 and PDF Editor before 2024.1, code execution via JavaScript could occur because of an unoptimized prompt message for users to review parameters of commands.
Affected products
- Foxit PDF Reader: before 2024.4 — fixed in 2024.4
- Foxit Pdf Reader: before 2024.4 — fixed in 2024.4
How to fix
Upgrade to a fixed version: Foxit PDF Reader 2024.4; Foxit Pdf Reader 2024.4. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2024-25858 or the next vulnerability affects your stack