What’s Vulnerable › Vulnerabilities
CVE-2024-25920: WordPress WP SMS plugin <= 6.3.4 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VeronaLabs WP SMS allows Stored XSS.This issue affects WP SMS: from n/a through 6.3.4.
Affected products
- VeronaLabs WP SMS: before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: VeronaLabs WP SMS 6.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-sms/wordpress-wp-sms-plugin-6-3-4-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-sms/wordpress-wp-sms-plugin-6-3-4-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-25920 or the next vulnerability affects your stack