What’s Vulnerable › Vulnerabilities
CVE-2024-25935: WordPress RegistrationMagic plugin <= 5.2.5.9 - Broken Access Control vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in Metagauss RegistrationMagic.This issue affects RegistrationMagic: from n/a through 5.2.5.9.
Affected products
- Metagauss RegistrationMagic: before 5.2.6.0 — fixed in 5.2.6.0
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 5.2.6.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/custom-registration-form-builder-with-submission-manager/wordpress-registrationmagic-plugin-5-2-5-9-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/custom-registration-form-builder-with-submission-manager/wordpress-registrationmagic-plugin-5-2-5-9-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-25935 or the next vulnerability affects your stack