What’s Vulnerable › Vulnerabilities
CVE-2024-25949
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-285
Description
Dell OS10 Networking Switches, versions10.5.6.x, 10.5.5.x, 10.5.4.x and 10.5.3.x ,contain an improper authorization vulnerability. A remote authenticated attacker could potentially exploit this vulnerability leading to escalation of privileges.
Affected products
- Dell Networking OS10: from 10.5.3.0 before 10.5.3.10; from 10.5.4.0 before 10.5.4.11; from 10.5.5.0 before 10.5.5.8; 10.5.6.0 — fixed in 10.5.3.10, 10.5.4.11, 10.5.5.8
How to fix
Upgrade to a fixed version: Dell Networking OS10 10.5.3.10, 10.5.4.11, 10.5.5.8. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000225922/dsa-2024-087-security-update-for-dell-networking-os10-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000225922/dsa-2024-087-security-update-for-dell-networking-os10-vulnerability
Get alerted when CVE-2024-25949 or the next vulnerability affects your stack