What’s Vulnerable › Vulnerabilities
CVE-2024-25973: Multiple Stored Cross-Site Scripting Vulnerabilities
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-20
Description
The Frentix GmbH OpenOlat LMS is affected by multiple stored Cross-Site Scripting (XSS) vulnerabilities. An attacker with rights to create or edit groups can create a course with a name that contains an XSS payload. Furthermore, attackers with the permissions to create or rename a catalog (sub-category) can enter unfiltered input in the name field. In addition, attackers who are allowed to create curriculums can also enter unfiltered input in the name field. This allows an attacker to execute stored JavaScript code with the permissions of the victim in the context of the user's browser.
Affected products
- OpenOLAT: before 18.1.6 — fixed in 18.1.6
How to fix
Upgrade to a fixed version: OpenOLAT 18.1.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2024/Feb/23
- https://r.sec-consult.com/openolat
- http://seclists.org/fulldisclosure/2024/Feb/23
- https://r.sec-consult.com/openolat
Get alerted when CVE-2024-25973 or the next vulnerability affects your stack