What’s Vulnerable › Vulnerabilities
CVE-2024-25974: Stored Cross-Site Scripting (XSS) within the Media Center
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-20
Description
The Frentix GmbH OpenOlat LMS is affected by stored a Cross-Site Scripting (XSS) vulnerability. It is possible to upload files within the Media Center of OpenOlat version 18.1.5 (or lower) as an authenticated user without any other rights. Although the filetypes are limited, an SVG image containing an XSS payload can be uploaded. After a successful upload the file can be shared with groups of users (including admins) who can be attacked with the JavaScript payload.
Affected products
- OpenOLAT: before 18.1.6 — fixed in 18.1.6
How to fix
Upgrade to a fixed version: OpenOLAT 18.1.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2024/Feb/23
- https://r.sec-consult.com/openolat
- http://seclists.org/fulldisclosure/2024/Feb/23
- https://r.sec-consult.com/openolat
Get alerted when CVE-2024-25974 or the next vulnerability affects your stack