What’s Vulnerable › Vulnerabilities
CVE-2024-25978: Msa-24-0001: denial of service risk in file picker unzip functionality
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-19 · updated 2026-06-17
- Weakness: CWE-400
Description
Insufficient file size checks resulted in a denial of service risk in the file picker's unzip functionality.
Affected products
- Fedoraproject Fedora: 38
- Moodle: from 4.1.0 before 4.1.9; from 4.2.0 before 4.2.6; from 4.3.0 before 4.3.3 — fixed in 4.1.9, 4.2.6, 4.3.3
How to fix
Upgrade to a fixed version: Moodle 4.1.9, 4.2.6, 4.3.3. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-74641
- https://bugzilla.redhat.com/show_bug.cgi?id=2264074
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB/
- https://moodle.org/mod/forum/discuss.php?d=455634
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-74641
- https://bugzilla.redhat.com/show_bug.cgi?id=2264074
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB/
- https://moodle.org/mod/forum/discuss.php?d=455634
Get alerted when CVE-2024-25978 or the next vulnerability affects your stack