What’s Vulnerable › Vulnerabilities
CVE-2024-25982: Msa-24-0005: csrf risk in language import utility
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The link to update all installed language packs did not include the necessary token to prevent a CSRF risk.
Affected products
- Fedoraproject Fedora: 38
- Moodle: from 4.1.0 before 4.1.9; from 4.2.0 before 4.2.6; from 4.3.0 before 4.3.3 — fixed in 4.1.9, 4.2.6, 4.3.3
How to fix
Upgrade to a fixed version: Moodle 4.1.9, 4.2.6, 4.3.3. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-54749
- https://bugzilla.redhat.com/show_bug.cgi?id=2264098
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB/
- https://moodle.org/mod/forum/discuss.php?d=455638
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-54749
- https://bugzilla.redhat.com/show_bug.cgi?id=2264098
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB/
- https://moodle.org/mod/forum/discuss.php?d=455638
Get alerted when CVE-2024-25982 or the next vulnerability affects your stack