What’s Vulnerable › Vulnerabilities
CVE-2024-25999: PHOENIX CONTACT: Privilege escalation in the OCPP agent service
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-20
Description
An unauthenticated local attacker can perform a privilege escalation due to improper input validation in the OCPP agent service.
Affected products
- Phoenixcontact Charx Sec-3000 Firmware: before 1.5.1 — fixed in 1.5.1
- Phoenixcontact Charx Sec-3050 Firmware: before 1.5.1 — fixed in 1.5.1
- Phoenixcontact Charx Sec-3100 Firmware: before 1.5.1 — fixed in 1.5.1
- Phoenixcontact Charx Sec-3150 Firmware: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Phoenixcontact Charx Sec-3000 Firmware 1.5.1; Phoenixcontact Charx Sec-3050 Firmware 1.5.1; Phoenixcontact Charx Sec-3100 Firmware 1.5.1; Phoenixcontact Charx Sec-3150 Firmware 1.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-25999 or the next vulnerability affects your stack