What’s Vulnerable › Vulnerabilities
CVE-2024-26010
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-10-22
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability in Fortinet FortiOS 7.4.0 through 7.4.3, FortiOS 7.2.0 through 7.2.7, FortiOS 7.0.0 through 7.0.14, FortiOS 6.4 all versions, FortiOS 6.2 all versions, FortiOS 6.0 all versions, FortiPAM 1.2 all versions, FortiPAM 1.1 all versions, FortiPAM 1.0 all versions, FortiProxy 7.4.0 through 7.4.3, FortiProxy 7.2.0 through 7.2.9, FortiProxy 7.0.0 through 7.0.16, FortiProxy 2.0 all versions, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions, FortiSwitchManager 7.2.0 through 7.2.3, FortiSwitchManager 7.0.1 through 7.0.3 allows attacker to execute unauthorized code or commands via specially crafted packets.
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.0 before 7.0.15; from 7.2.0 before 7.2.8; from 7.4.0 before 7.4.4 — fixed in 7.0.15, 7.2.8, 7.4.4
- Fortinet FortiPAM: from 1.0.0 through 1.3.0
- Fortinet FortiProxy: from 1.0.0 before 7.0.17; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.4 — fixed in 7.0.17, 7.2.10, 7.4.4
- Fortinet FortiSwitchManager: from 7.0.1 before 7.0.4; from 7.2.0 before 7.2.4 — fixed in 7.0.4, 7.2.4
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.15, 7.2.8, 7.4.4; Fortinet FortiProxy 7.0.17, 7.2.10, 7.4.4; Fortinet FortiSwitchManager 7.0.4, 7.2.4. Check the vendor advisory for mitigations.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-24-036
- https://fortiguard.fortinet.com/psirt/FG-IR-24-036
Get alerted when CVE-2024-26010 or the next vulnerability affects your stack