What’s Vulnerable › Vulnerabilities
CVE-2024-26011
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-10-22
- Weakness: CWE-306
Description
A missing authentication for critical function vulnerability in Fortinet FortiManager 7.4.0 through 7.4.2, FortiManager 7.2.0 through 7.2.4, FortiManager 7.0.0 through 7.0.11, FortiManager 6.4.0 through 6.4.14, FortiOS 7.4.0 through 7.4.3, FortiOS 7.2.0 through 7.2.7, FortiOS 7.0.0 through 7.0.14, FortiOS 6.4 all versions, FortiOS 6.2 all versions, FortiOS 6.0 all versions, FortiPAM 1.2 all versions, FortiPAM 1.1 all versions, FortiPAM 1.0 all versions, FortiPortal 6.0.0 through 6.0.14, FortiPortal 5.3 all versions, FortiProxy 7.4.0 through 7.4.3, FortiProxy 7.2.0 through 7.2.9, FortiProxy 7.0.0 through 7.0.16, FortiProxy 2.0 all versions, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions, FortiSwitchManager 7.2.0 through 7.2.3, FortiSwitchManager 7.0.0 through 7.0.3 allows attacker to execute unauthorized code or commands via specially crafted packets.
Affected products
- Fortinet FortiManager: from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.12; from 7.2.0 before 7.2.5; from 7.4.0 before 7.4.3 — fixed in 6.4.15, 7.0.12, 7.2.5, 7.4.3
- Fortinet FortiOS (FortiGate): from 6.0.0 before 7.0.15; from 7.2.0 before 7.2.8; from 7.4.0 before 7.4.4 — fixed in 7.0.15, 7.2.8, 7.4.4
- Fortinet FortiPAM: from 1.0.0 before 1.3.0 — fixed in 1.3.0
- Fortinet FortiPortal: from 5.3.0 before 6.0.15 — fixed in 6.0.15
- Fortinet FortiProxy: from 1.0.0 before 7.0.17; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.4 — fixed in 7.0.17, 7.2.10, 7.4.4
- Fortinet FortiSwitchManager: from 7.0.0 before 7.0.4; from 7.2.0 before 7.2.4 — fixed in 7.0.4, 7.2.4
How to fix
Upgrade to a fixed version: Fortinet FortiManager 6.4.15, 7.0.12, 7.2.5, 7.4.3; Fortinet FortiOS (FortiGate) 7.0.15, 7.2.8, 7.4.4; Fortinet FortiPAM 1.3.0; Fortinet FortiPortal 6.0.15; Fortinet FortiProxy 7.0.17, 7.2.10, 7.4.4; Fortinet FortiSwitchManager 7.0.4, 7.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-26011 or the next vulnerability affects your stack