What’s Vulnerable › Vulnerabilities
CVE-2024-26012
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') in Fortinet FortiAP-S 6.2 all verisons, and 6.4.0 through 6.4.9, FortiAP-W2 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.3, and 7.4.0 through 7.4.2, FortiAP 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.3, and 7.4.0 through 7.4.2 allow a local authenticated attacker to execute unauthorized code via the CLI.
Affected products
- Fortinet FortiAP: from 6.4.1 before 7.2.4; from 7.4.0 before 7.4.3 — fixed in 7.2.4, 7.4.3
- Fortinet FortiAP-S: from 6.2.0 before 6.4.10 — fixed in 6.4.10
- Fortinet FortiAP-W2: from 6.4.0 before 7.2.4; from 7.4.0 before 7.4.3 — fixed in 7.2.4, 7.4.3
How to fix
Upgrade to a fixed version: Fortinet FortiAP 7.2.4, 7.4.3; Fortinet FortiAP-S 6.4.10; Fortinet FortiAP-W2 7.2.4, 7.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-26012 or the next vulnerability affects your stack