What’s Vulnerable › Vulnerabilities
CVE-2024-26016: Apache Superset: Improper authorization validation on dashboards and charts import
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-863
Description
A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Affected products
- Apache Superset: before 3.0.4; from 3.1.0 before 3.1.1 — fixed in 3.0.4, 3.1.1
How to fix
Upgrade to a fixed version: Apache Superset 3.0.4, 3.1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/28/7
- https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s
- http://www.openwall.com/lists/oss-security/2024/02/28/7
- https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s
Get alerted when CVE-2024-26016 or the next vulnerability affects your stack