What’s Vulnerable › Vulnerabilities
CVE-2024-2603: Salon booking system <= 9.6.5 - Editor+ Stored XSS via Email Settings
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Salon booking system WordPress plugin through 9.6.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin (or editor depending on Salon booking system WordPress plugin through 9.6.5 configuration) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Salon booking system: before 9.6.6 — fixed in 9.6.6
How to fix
Upgrade to a fixed version: Salon booking system 9.6.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b4186c03-99ee-4297-85c0-83b7053afc1c/
- https://wpscan.com/vulnerability/b4186c03-99ee-4297-85c0-83b7053afc1c/
Get alerted when CVE-2024-2603 or the next vulnerability affects your stack