What’s Vulnerable › Vulnerabilities
CVE-2024-2606
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-704
Description
Passing invalid data could have led to invalid wasm values being created, such as arbitrary integers turning into pointer values. This vulnerability affects Firefox < 124.
Affected products
- Mozilla Firefox: before 124.0 — fixed in 124.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 124.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1879237
- https://www.mozilla.org/security/advisories/mfsa2024-12/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1879237
- https://www.mozilla.org/security/advisories/mfsa2024-12/
Get alerted when CVE-2024-2606 or the next vulnerability affects your stack