What’s Vulnerable › Vulnerabilities
CVE-2024-26140: com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
Affected products
- yetanalytics lrs: before 1.2.17 — fixed in 1.2.17
- yetanalytics Sql Lrs: before 0.7.5 — fixed in 0.7.5
How to fix
Upgrade to a fixed version: yetanalytics lrs 1.2.17; yetanalytics Sql Lrs 0.7.5. Check the vendor advisory for mitigations.
References
- https://clojars.org/com.yetanalytics/lrs/versions/1.2.17
- https://github.com/yetanalytics/lrs/commit/d7f4883bc2252337d25e8bba2c7f9d172f5b0621
- https://github.com/yetanalytics/lrs/releases/tag/v1.2.17
- https://github.com/yetanalytics/lrs/security/advisories/GHSA-7rw2-3hhp-rc46
- https://github.com/yetanalytics/lrsql/releases/tag/v0.7.5
- https://clojars.org/com.yetanalytics/lrs/versions/1.2.17
- https://github.com/yetanalytics/lrs/commit/d7f4883bc2252337d25e8bba2c7f9d172f5b0621
- https://github.com/yetanalytics/lrs/releases/tag/v1.2.17
- https://github.com/yetanalytics/lrs/security/advisories/GHSA-7rw2-3hhp-rc46
- https://github.com/yetanalytics/lrsql/releases/tag/v0.7.5
Get alerted when CVE-2024-26140 or the next vulnerability affects your stack