What’s Vulnerable › Vulnerabilities
CVE-2024-26141: Possible DoS Vulnerability with Range Header in Rack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-400
Description
Rack is a modular Ruby web server interface. Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the `Rack::File` middleware or the `Rack::Utils.byte_ranges` methods (this includes Rails applications). The vulnerability is fixed in 3.0.9.1 and 2.2.8.1.
Affected products
- Debian Linux: 10.0
- rack: from 1.3.0 before 2.2.8.1; from 3.0.0 before 3.0.9.1 — fixed in 2.2.8.1, 3.0.9.1
- Rubygems Rack: from 3.0.0 before 3.0.9.1; from 1.3.0 before 2.2.8.1; 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.4.1 (+88) — fixed in 3.0.9.1, 2.2.8.1
How to fix
Upgrade to a fixed version: rack 2.2.8.1, 3.0.9.1; Rubygems Rack 3.0.9.1, 2.2.8.1. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/possible-dos-vulnerability-with-range-header-in-rack/84944
- https://github.com/rack/rack/commit/4849132bef471adb21131980df745f4bb84de2d9
- https://github.com/rack/rack/commit/62457686b26d33a15a254c7768c2076e8e02b48b
- https://github.com/rack/rack/security/advisories/GHSA-xj5v-6v4g-jfw6
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26141.yml
- https://lists.debian.org/debian-lts-announce/2024/04/msg00022.html
- https://security.netapp.com/advisory/ntap-20240510-0007/
- https://discuss.rubyonrails.org/t/possible-dos-vulnerability-with-range-header-in-rack/84944
- https://github.com/rack/rack/commit/4849132bef471adb21131980df745f4bb84de2d9
- https://github.com/rack/rack/commit/62457686b26d33a15a254c7768c2076e8e02b48b
- https://github.com/rack/rack/security/advisories/GHSA-xj5v-6v4g-jfw6
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26141.yml
Get alerted when CVE-2024-26141 or the next vulnerability affects your stack