What’s Vulnerable › Vulnerabilities

CVE-2024-26146: Possible Denial of Service Vulnerability in Rack Header Parsing

Description

Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.

Affected products

How to fix

Upgrade to a fixed version: rack 2.0.9.4, 2.1.4.4, 2.2.8.1; Rubygems Rack 3.0.9.1, 2.2.8.1, 2.1.4.4, 2.0.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-26146 or the next vulnerability affects your stack