What’s Vulnerable › Vulnerabilities
CVE-2024-26148: Querybook's Stored Cross-Site Scripting vulnerability allows Privilege Elevation
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Querybook is a user interface for querying big data. Prior to version 3.31.1, there is a vulnerability in Querybook's rich text editor that enables users to input arbitrary URLs without undergoing necessary validation. This particular security flaw allows the use of `javascript:` protocol which can potentially trigger arbitrary client-side execution. The most extreme exploit of this flaw could occur when an admin user unknowingly clicks on a cross-site scripting URL, thereby unintentionally compromising admin role access to the attacker. A patch to rectify this issue has been introduced in Querybook version `3.31.1`. The fix is backward compatible and automatically fixes existing DataDocs. There are no known workarounds for this issue, except for manually checking each URL prior to clicking on them.
Affected products
- pinterest querybook: before 3.31.1 — fixed in 3.31.1
How to fix
Upgrade to a fixed version: pinterest querybook 3.31.1. Check the vendor advisory for mitigations.
References
- https://github.com/pinterest/querybook/commit/bc620dabaaf13ff1dcb30af0b46a490403fb9908
- https://github.com/pinterest/querybook/pull/1412
- https://github.com/pinterest/querybook/security/advisories/GHSA-fh6g-gvvp-587f
- https://github.com/pinterest/querybook/commit/bc620dabaaf13ff1dcb30af0b46a490403fb9908
- https://github.com/pinterest/querybook/pull/1412
- https://github.com/pinterest/querybook/security/advisories/GHSA-fh6g-gvvp-587f
Get alerted when CVE-2024-26148 or the next vulnerability affects your stack