What’s Vulnerable › Vulnerabilities
CVE-2024-2619: Elementor Header & Footer Builder <= 1.6.26 - Authenticated (Author+) HTML Injection
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Elementor Header & Footer Builder for WordPress is vulnerable to HTML Injection in all versions up to, and including, 1.6.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level permissions and above, to inject arbitrary HTML in pages that will be shown whenever a user accesses an injected page.
Affected products
- brainstormforce Ultimate Addons for Elementor: before 1.6.27 — fixed in 1.6.27
How to fix
Upgrade to a fixed version: brainstormforce Ultimate Addons for Elementor 1.6.27. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.25/admin/class-hfe-admin.php#L220
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.25/admin/class-hfe-admin.php#L74
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3070659%40header-footer-elementor%2Ftrunk&old=3053177%40header-footer-elementor%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/689eb95b-2f72-4aa4-9f21-6ae186346061?source=cve
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.25/admin/class-hfe-admin.php#L220
- https://plugins.trac.wordpress.org/browser/header-footer-elementor/tags/1.6.25/admin/class-hfe-admin.php#L74
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3070659%40header-footer-elementor%2Ftrunk&old=3053177%40header-footer-elementor%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/689eb95b-2f72-4aa4-9f21-6ae186346061?source=cve
Get alerted when CVE-2024-2619 or the next vulnerability affects your stack