What’s Vulnerable › Vulnerabilities

CVE-2024-26266

Description

Multiple stored cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.2.0 through 7.4.3.13, and older unsupported versions, and Liferay DXP 7.4 before update 10, 7.3 before update 4, 7.2 before fix pack 17, and older unsupported versions allow remote authenticated users to inject arbitrary web script or HTML via a crafted payload injected into the first/middle/last name text field of the user who creates an entry in the (1) Announcement widget, or (2) Alerts widget.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 7.2; Liferay Portal 7.4.3.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-26266 or the next vulnerability affects your stack