What’s Vulnerable › Vulnerabilities

CVE-2024-26269

Description

Cross-site scripting (XSS) vulnerability in the Frontend JS module's portlet.js in Liferay Portal 7.2.0 through 7.4.3.37, and Liferay DXP 7.4 before update 38, 7.3 before update 11, 7.2 before fix pack 20, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via the anchor (hash) part of a URL.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 7.2; Liferay Portal 7.4.3.38. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-26269 or the next vulnerability affects your stack