What’s Vulnerable › Vulnerabilities
CVE-2024-26279: [20240704] - Core - XSS in Wrapper extensions
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The wrapper extensions do not correctly validate inputs, leading to XSS vectors.
Affected products
- Joomla!: from 3.0.0 before 3.10.16; from 4.0.0 before 4.4.6; from 5.0.0 before 5.1.2 — fixed in 3.10.16, 4.4.6, 5.1.2
How to fix
Upgrade to a fixed version: Joomla! 3.10.16, 4.4.6, 5.1.2. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/938-20240704-core-xss-in-wrapper-extensions.html
- https://developer.joomla.org/security-centre/938-20240704-core-xss-in-wrapper-extensions.html
Get alerted when CVE-2024-26279 or the next vulnerability affects your stack