What’s Vulnerable › Vulnerabilities
CVE-2024-26280: Apache Airflow: Overly broad default permissions for Viewer/Ops (audit logs)
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-276
Description
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated Ops and Viewers users to view all information on audit logs, including dag names and usernames they were not permitted to view. With 2.8.2 and newer, Ops and Viewer users do not have audit log permission by default, they need to be explicitly granted permissions to see the logs. Only admin users have audit log permission by default. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Affected products
- Apache Airflow: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.8.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/01/1
- https://github.com/apache/airflow/pull/37501
- https://lists.apache.org/thread/knskxxxml95091rsnpxkpo1jjp8rj0fh
- http://www.openwall.com/lists/oss-security/2024/03/01/1
- https://github.com/apache/airflow/pull/37501
- https://lists.apache.org/thread/knskxxxml95091rsnpxkpo1jjp8rj0fh
Get alerted when CVE-2024-26280 or the next vulnerability affects your stack