What’s Vulnerable › Vulnerabilities
CVE-2024-26290: Authenticated Remote Command Injection affecting Avid NEXIS
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Avid Avid NEXIS E-series on Linux, Avid Avid NEXIS F-series on Linux, Avid Avid NEXIS PRO+ on Linux, Avid System Director Appliance (SDA+) on Linux allows code execution on underlying operating system with root permissions.This issue affects Avid NEXIS E-series: before 2024.6.0; Avid NEXIS F-series: before 2024.6.0; Avid NEXIS PRO+: before 2024.6.0; System Director Appliance (SDA+): before 2024.6.0.
Affected products
- Avid NEXIS E-series: before 2024.6.0 — fixed in 2024.6.0
- Avid NEXIS F-series: before 2024.6.0 — fixed in 2024.6.0
- Avid NEXIS PRO+: before 2024.6.0 — fixed in 2024.6.0
- Avid System Director Appliance (SDA+): before 2024.6.0 — fixed in 2024.6.0
How to fix
Upgrade to a fixed version: Avid NEXIS E-series 2024.6.0; Avid NEXIS F-series 2024.6.0; Avid NEXIS PRO+ 2024.6.0; Avid System Director Appliance (SDA+) 2024.6.0. Check the vendor advisory for mitigations.
References
- https://kb.avid.com/pkb/articles/troubleshooting/en239659
- https://www.drive-byte.de/en/blog/avid-nexis-agent-multiple-vulnerabilities
- https://raeph123.github.io/BlogPosts/Avid_Nexis/Advisory_Avid_Nexus_Agent_Multiple_Vulnerabilities_en.html
Get alerted when CVE-2024-26290 or the next vulnerability affects your stack