What’s Vulnerable › Vulnerabilities
CVE-2024-26293: Unauthenticated Path Traversal affecting Avid NEXIS
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-1395
Description
The Avid Nexis Agent uses a vulnerable gSOAP version. An undocumented vulnerability impacting gSOAP v2.8 makes the application vulnerable to an Unauthenticated Path Traversal vulnerability. This issue affects Avid NEXIS E-series: before 2025.5.1; Avid NEXIS F-series: before 2025.5.1; Avid NEXIS PRO+: before 2025.5.1; System Director Appliance (SDA+): before 2025.5.1.
Affected products
- Avid NEXIS E-series: before 2025.5.1 — fixed in 2025.5.1
- Avid NEXIS F-series: before 2025.5.1 — fixed in 2025.5.1
- Avid NEXIS PRO+: before 2025.5.1 — fixed in 2025.5.1
- Avid System Director Appliance (SDA+): before 2025.5.1 — fixed in 2025.5.1
How to fix
Upgrade to a fixed version: Avid NEXIS E-series 2025.5.1; Avid NEXIS F-series 2025.5.1; Avid NEXIS PRO+ 2025.5.1; Avid System Director Appliance (SDA+) 2025.5.1. Check the vendor advisory for mitigations.
References
- https://raeph123.github.io/BlogPosts/Avid_Nexis/Advisory_Avid_Nexus_Agent_Multiple_Vulnerabilities_en.html
- https://resources.avid.com/SupportFiles/attach/AvidNEXIS/AvidNEXIS_2025_5_1_ReadMe.pdf
- https://www.genivia.com/changelog.html
Get alerted when CVE-2024-26293 or the next vulnerability affects your stack