What’s Vulnerable › Vulnerabilities
CVE-2024-26308: Apache Commons Compress: OutOfMemoryError unpacking broken Pack200 file
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-19 · updated 2026-06-17
- Weakness: CWE-770
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.21 before 1.26. Users are recommended to upgrade to version 1.26, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Compress: from 1.21 before 1.26.0 — fixed in 1.26.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Compress 1.26.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/19/2
- https://lists.apache.org/thread/ch5yo2d21p7vlqrhll9b17otbyq4npfg
- https://security.netapp.com/advisory/ntap-20240307-0009/
- http://www.openwall.com/lists/oss-security/2024/02/19/2
- https://lists.apache.org/thread/ch5yo2d21p7vlqrhll9b17otbyq4npfg
- https://security.netapp.com/advisory/ntap-20240307-0009/
Get alerted when CVE-2024-26308 or the next vulnerability affects your stack