What’s Vulnerable › Vulnerabilities
CVE-2024-2640: Watu Quiz < 3.4.1.2 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Watu Quiz WordPress plugin before 3.4.1.2 does not sanitise and escape some of its settings, which could allow users such as authors (if they've been authorized by admins) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Bob Watu Quiz: before 3.4.1.2 — fixed in 3.4.1.2
How to fix
Upgrade to a fixed version: Bob Watu Quiz 3.4.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d46db635-9d84-4268-a789-406a0db4cccf/
- https://wpscan.com/vulnerability/d46db635-9d84-4268-a789-406a0db4cccf/
Get alerted when CVE-2024-2640 or the next vulnerability affects your stack