What’s Vulnerable › Vulnerabilities
CVE-2024-2643: My Sticky Bar < 2.6.8 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any WordPress plugin before 2.6.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme 2.6.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/194ebf81-8fe4-4c74-8174-35d0ac00ac93/
- https://wpscan.com/vulnerability/194ebf81-8fe4-4c74-8174-35d0ac00ac93/
Get alerted when CVE-2024-2643 or the next vulnerability affects your stack