What’s Vulnerable › Vulnerabilities
CVE-2024-26481
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter.
Affected products
- getkirby kirby: before 3.6.6.5; from 3.7.0 before 3.7.5.4; from 3.8.0 before 3.8.4.3; from 3.9.0 before 3.9.8.1; from 4.0.0 through 4.1.1; 3.10.0 — fixed in 3.6.6.5, 3.7.5.4, 3.8.4.3, 3.9.8.1
How to fix
Upgrade to a fixed version: getkirby kirby 3.6.6.5, 3.7.5.4, 3.8.4.3, 3.9.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-57f2-8p89-66x6
- https://shrouded-trowel-50c.notion.site/Kirby-CMS-4-1-0-Self-Cross-Site-Scripting-d877183d20af49f8a8f58554bc06d51c?pvs=4
- https://github.com/getkirby/kirby/security/advisories/GHSA-57f2-8p89-66x6
- https://shrouded-trowel-50c.notion.site/Kirby-CMS-4-1-0-Self-Cross-Site-Scripting-d877183d20af49f8a8f58554bc06d51c?pvs=4
Get alerted when CVE-2024-26481 or the next vulnerability affects your stack