What’s Vulnerable › Vulnerabilities
CVE-2024-26521
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
HTML Injection vulnerability in CE Phoenix v1.0.8.20 and before allows a remote attacker to execute arbitrary code, escalate privileges, and obtain sensitive information via a crafted payload to the english.php component.
Affected products
- osCommerce Ce Phoenix: before 1.0.8.20 — fixed in 1.0.8.20
How to fix
Upgrade to a fixed version: osCommerce Ce Phoenix 1.0.8.20. Check the vendor advisory for mitigations.
References
- https://github.com/capture0x/Phoenix
- https://github.com/hackervegas001/CVE-2024-26521
- https://github.com/capture0x/Phoenix
- https://github.com/hackervegas001/CVE-2024-26521
Get alerted when CVE-2024-26521 or the next vulnerability affects your stack